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LI�ÌO 3: CONCEITOS BçSICOS DE  INTERATIVIDADE

OBJETIVOS

Nesta lição, você aprenderá a :

• tornar seu filme do Flash interativo
• aplicar ações a quadros específicos
• criar botões interativos
• criar e editar símbolos na Biblioteca

CONTEXTO

Até agora, você construiu animações com várias camadas a partir do zero. Quando você publicar seu

filme na Web, poderá deixar que ele seja executado inúmeras vezes. Mas você não acha que os

visitantes de seu site da Web ficariam felizes se pudessem iniciar, interromper e controlar a animação?

O Flash oferece um grande conjunto de ferramentas para adicionar interatividade a seus filmes. Você

poderá aplicar controles a quadros individuais de seu filme ou criar botões que iniciem ações, como

começar uma animação, interromper, alternar entre as cenas e, até mesmo, iniciar outros sites da Web.

EXERCêCIOS

ATRIBUINDO UMA AÇÃO A UM QUADRO

O Flash proporciona uma variedade de Ações que podem ser aplicadas a quadros ou botões. As ações

incluem iniciar ou interromper uma animação, pular para um quadro em particular, alternar para uma cena

diferente no filme ou ir para uma outra página da Web. Você começará com um exemplo simples:

adicionar uma ação de quadro (Frame Action) ao filme da formiga para que o filme entre em loop.

Use o Recurso Go To Action para Fazer Seu Filme Entrar em Loop

Você pode querer que seu filme entre em loop, o que significa que ele irá ser executado sem parar.
Embora você possa definir um atributo “loop” para a guia HTML que executa seu filme na Web
(consulte a Lição 6 para obter mais detalhes), talvez queira construir essa função no próprio filme.

Se seu filme ant.fla não estiver aberto atualmente, abra-o agora e dirija-se à cena Animation construída
na lição anterior.

1. Primeiro, verifique se a opção Loop Playback está ativada no menu Control. Caso esteja, selecione-
a novamente para desativá-la (a marca de seleção deverá desaparecer).

2. Execute seu filme com o controlador. Observe que a animação é executada apenas uma vez e
depois pára. Agora, você irá adicionar um nova ação de quadro para deixar o filme ser executado
inúmeras vezes.

3. É uma boa idéia colocar as ações de quadro em suas próprias camadas. Escolha Insert > Layer e dê
o nome de “Actions” à nova camada.

4. Clique no quadro 20 da linha de tempo Actions. Esse deverá ser o último quadro de toda a animação.
5. Escolha Insert > Keyframe para adicionar um quadro-chave ao quadro 20. Você só pode aplicar

ações a quadros-chave.
6. Clique duas vezes no quadro 20 para abrir a caixa de diálogo Frame Properties.
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7. Clique na guia Actions.

8. O primeiro botão mostra um sinal de mais e uma pequena seta. Clique no botão + para ter acesso
às várias ações que podem ser adicionadas ao quadro. Selecione Go To. O Flash incluirá esse
comando na lista de ações do lado esquerdo.

9. A área Parameters será exibida à direita. Deixe a maioria das opções em suas definições padrão.
Selecione a caixa ao lado de Go to and Play (Figura 3-1). 

10. Clique em OK para terminar. Você acabou de indicar ao Flash que, quando a animação atingir o
último quadro, ela deverá retornar ao quadro inicial e ser executada novamente. Isso ocorrerá todas
as vezes em que a animação terminar, criando um loop sem fim.

11. Escolha Control > Enable Frame Actions para mostrar como a ação irá funcionar.
12. Usando o controlador, execute a animação. Com a ação de quadro que você acabou de adicionar, o

filme deve, mais uma vez, entrar em loop continuamente.

CRIANDO BOTÕES INTERATIVOS

As mesmas ações vistas na caixa de diálogo Frame Action podem ser adicionadas aos botões em sua

animação, nos quais os usuários poderão clicar para controlar o filme. Você incluirá três botões de

controle em sua animação: Parar (Stop), Iniciar (Start) e Informações sobre o Flash (Flash Info), que

levarão os usuários ao site do Macromedia Flash na Web.

Observe que os botões devem ser símbolos, embora você possa converter um desenho normal em um

botão, transformando-o em um símbolo.

Crie um Botão PARAR

1. Certifique-se de que nada está atualmente selecionado no Stage.
2. Escolha Insert > Create Symbol.
3. Na caixa de diálogo Symbol Properties, digite o nome “Stop” e selecione Button na opção

Behavior. Em seguida, clique em OK para terminar.
4. A tela muda para o modo de edição de símbolo. O cursor de mira no meio do Stage fornece um

ponto de referência para o centro de seu botão. Observe também que a exibição de status de linha
de tempo (imediatamente abaixo da área Layers, conforme mostrado na Figura 3-2) se modifica para
indicar que você está editando um símbolo em vez de uma cena do filme. Observe que as guias do
lado direito se alteraram para fornecer acesso aos símbolos atuais de sua Biblioteca.

5. Use as ferramentas de desenho para desenhar um botão simples. Selecione a ferramenta Pencil no
modo Rectangle. Escolha um azul intenso e uma linha contínua de um ponto. Desenhe um retângulo
centralizado ao redor do cursor de mira.

Figura 3-1
A guia Actions na
caixa de diálogo
Frame Properties



6. Adicione texto ao seu botão. Escolha a ferramenta Text e selecione o azul como a cor do texto.
Defina o tipo como Helvetica ou Arial, 18 pontos, Negrito. Clique com a ferramenta Text dentro do
retângulo e digite “STOP”. Use a ferramenta Arrow para posicionar o texto de modo que ele fique
centralizado sobre o botão. Caso precise alterar o tamanho do texto, faça-o agora.

7. Salve seu trabalho.

Adicione Estados ao Botão

Todo botão do Flash possui quatro estados diferentes: Up, Over, Down e Hit. O quadro Up é o padrão
para o botão. O quadro Over é exibido quando um usuário passa o cursor sobre o botão. O quadro Down
é exibido enquanto o botão está sendo clicado. O quadro Hit é um pouco diferente em relação aos outros
estados; ele indica que área do botão realmente responde a um clique do mouse. O usuário, na verdade,
nunca verá o quadro Hit, por isso ele pode ser maior ou menor do que o imagem do botão em si.

Observe como o Flash já criou quadros para esses quatro estados em sua linha de tempo de símbolo do
botão. Neste exercício, você criará imagens para os quatro quadros de seu botão STOP. Consulte a
Figura 3-3 para ver como eles devem ficar.

1. Os quatro estados dos botões estão listados na parte superior da linha de tempo da Layer 1. O
estado Up já possui um quadro-chave e uma imagem, que é o botão que você acabou de criar. Na
linha de tempo, clique e arraste desde o quadro Over até o quadro Hit para selecionar os três
quadros vazios.

2. Escolha Insert > Keyframe.
3. Clique no quadro Over na linha de tempo para trabalhar com o estado Over do botão
4. Selecione a ferramenta Paint Bucket a partir da barra de ferramentas e escolha um azul-claro a partir

do menu pop-up Fill Color. Preencha a parte de dentro do retângulo do botão com esse azul claro.
5. Clique no quadro Down na linha de tempo.
6. Selecione a ferramenta Text e destaque a palavra “STOP” no botão dando um clique duplo nela. No

menu pop-up Text Color na barra de ferramentas, selecione branco para deixar o texto branco.
7. Selecione a ferramenta Paint Bucket e escolha um azul-intenso parecido com a borda do botão.

Preencha a parte interna do botão com essa cor.
8. Alterar o quadro Hit será um pouco mais complicado. Primeiro, clique no quadro Hit na linha de tempo.
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Figura 3-2
A linha de tempo e o Stage no
modo de edição de símbolo.
Observe que a exibição de status
da linha de tempo indica que
você está trabalhando em um 
botão chamado Stop.
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9. Para selecionar rapidamente todas as partes do botão, escolha Edit > Select All. Agora, exclua o
botão usando as teclas Backspace ou Delete.

10. Ative o modo Onion Skinning usando o botão Onion Skin na parte superior esquerda da linha de
tempo. Você deverá ver um retângulo azul no lugar em que o botão foi desenhado.

11. Selecione a ferramenta Pencil no modo Rectangle. Escolha o preto a partir do menu pop-up Line
Color. No Stage, desenhe um retângulo sobre o retângulo azul do botão. O retângulo preto deve
ser pelo menos tão grande quanto o botão; ele pode ser um pouco maior, se você quiser.

12. Selecione a ferramenta Paintbucket com a cor preta como a cor de preenchimento. Preencha o
interior do retângulo preto. Essa área negra contínua é a área Hit do seu botão.

13. Salve seu trabalho.

Figura 3-3
Os quatro quadros do botão STOP: Up, Over, Down, e Hit.

Crie o Botão Iniciar Copiando a partir da Biblioteca

Como você acabou tendo todo o trabalho de criar o botão STOP, é bem provável que economize tempo
reutilizando-o para o botão START. Isso também irá garantir que os botões START e STOP fiquem com
o mesmo tamanho, cor e fonte.

1. Desative o modo Onion Skinning.

2. Escolha Window > Library. Observe que o botão Stop foi adicionado como um novo símbolo à
Biblioteca. Clique no nome “Stop” na lista de símbolos para selecioná-lo.

3. Na janela Library (Figura 3-4), a seta apontando para baixo na parte superior direita é o menu pop-up
Symbol. Clique nele e selecione Duplicate para criar uma cópia do botão STOP.

4. Uma nova caixa de diálogo Symbol Properties é exibida. Dê ao novo botão o nome de Start e clique
em OK.

5. A Biblioteca deve agora incluir o símbolo do novo botão
START. O botão (que atualmente se parece exatamente com
o botão STOP) deverá aparecer no Stage, com os quatro
estados intactos. Agora, o que você terá de fazer será alterar
o texto no botão, de “STOP” para “START”.

6. Na linha de tempo, clique no quadro Up.

7. Usando a ferramenta Text, selecione a palavra “STOP” no
botão e digite “START”.

8. Repita essa alteração para os quadros Over e Down. Não será
necessário alterar o quadro Hit.

9. Salve seu trabalho.

Figura 3-4
A janela Library



Crie o Botão Informações sobre o Flash

Você irá criar o último botão da mesma maneira, mas, provavelmente, terá de deixar o texto menor para
que ele caiba no botão.

1. Com o botão START selecionado na janela Library, escolha Duplicate no menu pop-up Symbol.

2. Na caixa de diálogo Symbol Properties, dê o nome de “Flash” ao novo botão e clique em OK.

3. Clique no quadro Up do novo botão na linha de tempo.

4. Usando a ferramenta Text, altere o texto do botão, de “START” para “Flash Info”. Destaque o
texto e altere o tamanho da fonte para 12 pontos.

5. Altere o texto nos botões Over e Down da mesma maneira.

6. Salve seu trabalho.

Adicione Botões à Sua Animação

Agora que você criou três botões, é hora de adicioná-los à sua animação e anexar as ações apropriadas.

1. Escolha Edit > Edit Movie para sair do modo de edição de símbolo e retornar ao seu filme animado.

2. Escolha Insert > Layer e dê à camada o nome de “Buttons”. Você colocará os botões nessa
camada.

3. Na janela Library, destaque o botão STOP. A imagem do botão deverá aparecer na parte superior
da janela. Arraste a imagem do botão para o Stage e coloque-a sob a grama na parte esquerda do
Stage.

4. Faça o mesmo com o botão START, colocando-o próximo ao botão STOP.

5. Arraste o botão Flash para o Stage, posicionando-o na parte inferior direita do Stage. O Stage
deverá ficar como na Figura 3-5.

Figura 3-5
Coloque os novos botões em suas respectivas camadas na animação.
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Defina Ações dos Botões

Finalmente, você irá adicionar as ações apropriadas aos seus botões.

1. Com a ferramenta Arrow, clique no botão STOP para selecioná-lo. 
2. Escolha Modify > Instance. (Uma Instância se refere a uma ocorrência de um símbolo da Biblioteca

colocado no Stage. Você poderá usar o botão STOP em diferentes lugares do filme; cada posição
será uma Instância separada.)

3. Quando a caixa Instance Properties for exibida, clique na guia Actions.
4. Clique no botão + e selecione Stop no menu pop-up Frame Actions. Como não existem parâmetros

a serem definidos, clique em OK para terminar.
5. Clique duas vezes no botão START. O clique duplo é um atalho à caixa de diálogo Instance

Properties. Na guia Actions, clique no botão + e selecione a ação Play. Clique em OK.
6. Clique duas vezes no botão Flash Info. Você programará esse botão para ir ao site do Macromedia

Flash na Web. Na guia Actions, clique no botão + e selecione Get URL. Na área Parameters, digite
“http://www.macromedia.com/flash” na área URL. Clique em OK para terminar.

7. Agora que você programou todos os botões, salve seu trabalho.

Teste Seus Botões

1. Escolha Control > Enable Buttons. Esse controle permite que seus botões funcionem
adequadamente no Stage. Se mais tarde você desejar editar os botões, precisará desativar a opção
Enable Buttons.

2. Usando o controlador, execute o filme.
3. Tente clicar em cada botão para ver como funciona. Observe quando os diferentes estados dos

botões são exibidos.
4. O botão Flash Info não funcionará a partir do Flash. Você o verá em ação na Lição 6 quando

exportar seu filme. Por enquanto, você terá de prosseguir acreditando que ele funciona.

MAIS EXERCÍCIOS PARA ESTIMULAR SUAS HABILIDADES

• Crie uma nova cena introdutória. Crie um botão “Iniciar o filme” e programe-o para alternar
para a cena Animation e executar o filme.

• Tente anexar diferentes ações aos botões e quadros em suas animações. Experimente
diferentes definições de parâmetros.

• Crie mais alguns botões. Experimente formas diferentes de alterar a aparência dos botões em
seus diferentes estados.

• Consulte os Tópicos da Ajuda e Demonstração do Flash (Guided Tour) para obter mais
informações sobre a adição de interatividade aos seus filmes.


